Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 11, 2026 - 08:00 UTC
Scheduled
A scheduled maintenance will take place on 11 March 2026 between 08:00 and 09:00 UTC. During this window, some BrandShelter services may be temporarily impacted.
Delayed processing of domain work requests Domain availability checks unavailable DNS zone publication to the default BrandShelter nameserver set unavailable (although DNS resolution is not expected to be impacted)
We apologise for any inconvenience this may cause.
Posted Mar 05, 2026 - 16:10 UTC
This scheduled maintenance affected: BrandShelter Portal (Production system), DNS (Standard nameserver set, Premium nameserver set), and Registry Connections.