We are continuing to monitor for any further issues.
Posted Mar 11, 2026 - 11:45 UTC
Monitoring
We experienced an issue affecting all clients using the BrandShelter portal. Unable to access the portal. Reason: We lost connection with a critical third party API causing pages to timeout and high load on servers. Root cause still being investigated and we are looking to enhance monitoring for future issues.
Posted Mar 11, 2026 - 10:50 UTC
This incident affected: BrandShelter Portal (Production system).